Инструменты пользователя

Инструменты сайта


Боковая панель

Software

Hardware

IoT

hardware:juniper:intervlan_routing

Маршрутизация между VLAN на одном коммутаторе

Для сегментирования трафика в сети на отдельные бродкастовые домены создаются логические («виртуальные») локальные сети - VLAN (Virtual Local Area Network). Например, можно создать отдельные VLAN для сотрудников разных отделов и для общих ресурсов сети, таких как принтеры, серверы и т.п.

И понятно, что может возникнуть ситуация, когда требуется связать компьютеры с другими компьютерами или ресурсами из других VLAN. Для пересылки пакетов между VLAN обычно используется маршрутизатор, который их объединит. Однако можно обойтись и без него, если сконфигурировать маршрутизируемый VLAN интерфейс - RVI (routed VLAN interface).

В нашем примере будем использовать RVI для включения маршрутизации между двумя VLAN на одном коммутаторе. Назовем их red и blue. Каждый VLAN должен иметь уникальное имя, тег (VLAN ID), и отдельную IP подсеть. Данные для нашего примера приведены в таблице

Параметры VLAN blue VLAN red
имя и тег VLAN blue, ID 100 red, ID 200
Подсети, назначенные VLAN 192.0.2.0/25 (адреса: 192.0.2.1 - 192.0.2.126) 192.0.2.128/25 (адреса: 192.0.2.129 - 192.0.2.254)
Интерфейсы xe-0/0/0, xe-0/0/2 xe-0/0/4, xe-0/0/6
RVI юниты и адреса логический unit 100: 192.0.2.1/25 логический unit 200: 192.0.2.129/25

Сопоставляем интерфейсы коммутатора соответствующим VLAN:

[edit interfaces xe-0/0/4 unit 0]
user@switch# set family ethernet-switching vlan members blue

[edit interfaces xe-0/0/6 unit 0]
user@switch# set family ethernet-switching vlan members blue

[edit interfaces xe-0/0/0 unit 0]
user@switch# set family ethernet-switching vlan members red

[edit interfaces xe-0/0/2 unit 0]
user@switch# set family ethernet-switching vlan members red

Создаем VLAN и RVI.

[edit vlans]
user@switch# set blue vlan-id 100
user@switch# set red vlan-id 200

[edit interfaces]
user@switch# set vlan unit 100 family inet address 192.0.2.1/25
user@switch# set vlan unit 200 family inet address 192.0.2.129/25

Завершаем конфигурацию RVI привязыванием VLAN red и blue (Layer 2) к соответствующим логическим юнитам vlan интерфейсов (Layer 3)

[edit vlans]
user@switch# set blue l3-interface vlan.100
user@switch# set red l3-interface vlan.200

В результате имеем конфигурацию:

user@switch> show configuration
interfaces {
     xe-0/0/4 {
          unit 0 {
               family ethernet-switching {
                    vlan members blue;
               }
          }
     }
     xe-0/0/6 {
          unit 0 {
               family ethernet-switching {
                    vlan members blue;
               }
          }
     }
     xe-0/0/0 {
          unit 0 {
               family ethernet-switching {
                    vlan members red;
               }
          }
     }
     xe-0/0/2 {
          unit 0 {
               family ethernet-switching {
                    vlan members red;
               }
          }
     }
     vlan {
          unit 100 {
               family inet address 192.0.2.1/25;
          }
          unit 200 {
               family inet address 192.0.2.129/25;
          }
     }
}
vlans {
     blue {
          vlan-id 100;
          interface xe-0/0/4.0;
          interface xe-0/0/6.0;
          l3-interface vlan 100;
     }
     red {
          vlan-id 200;
          interface xe-0/0/0.0;
          interface xe-0/0/2.0;
          l3-interface vlan 200;
     }
}
Совет: для быстрого конфигурирования можно набрать команду load merge terminal и скопировать иерархию конфигурации в окно терминала

Проверяем соответствие интерфейсов VLAN-ам:

user@switch> show vlans
Name       Tag         Interfaces
default                xe-0/0/0.0, xe-0/0/2.0, xe-0/0/4.0, xe-0/0/6.0,
blue       100         xe-0/0/4.0, xe-0/0/6,
red        200         xe-0/0/0.0, xe-0/0/2.0, *
mgmt                   me0.0*

Проверяем, что логические юниты RVI в состоянии up:

user@switch> show interfaces terse
vlan.100          up    up    inet    192.0.2.1/25
vlan.200          up    up    inet    192.0.2.129/25 
По крайней мере один порт (access или trunk) с соответствующим назначенным VLAN должен быть в up для того, чтобы интерфейс vlan был в up

Проверяем созданные маршруты, которые используют RVI интерфейсы:

user@switch> show route
192.0.2.0/25       *[Direct/0] 1d 03:26:45
                   > via vlan.100
192.0.2.1/32       *[Local/0] 1d 03:26:45
                   Local via vlan.100
192.0.2.128/25     *[Direct/0] 1d 03:26:45
                   > via vlan.200
192.0.2.129/32     *[Local/0] 1d 03:26:45
                   Local via vlan.200 

Проверяем маршруты Layer 3 в таблице Address Resolution Protocol (ARP):

user@switch> show arp
MAC Address           Address         Name         Flags
00:00:0c:06:2c:0d     192.0.2.7       vlan.100     None
00:13:e2:50:62:e0     192.0.2.132     vlan.200     None

Вывод команд show interfaces и show route говорит о том, что логические юниты Layer 3 RVI работают и коммутатор использует их для создания прямых маршрутов, предназначенных для транспорта трафика между VLAN подсетями. Команда show arp отображает соответствие IP адресов и MAC адресов для устройств в обоих VLAN-ах. Теперь устройства могут взаимодействовать.

hardware/juniper/intervlan_routing.txt · Последнее изменение: 2021/07/11 10:46 (внешнее изменение)